@related : AudioController Hardware Sound ALSA M5451 Audio MAO

[[lspci]]

0000:00:02.7 Multimedia audio controller: Silicon Integrated Systems [[SiS]] Sound Controller (rev a0)
0000:00:09.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
01:00.1 Multimedia audio controller: Neomagic Corporation NM2200 [[MagicMedia  256AV Audio]] (rev 20)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233 AC97 Audio  Controller (rev 10)
00:08.0 Multimedia audio controller: ALi Corporation [[M5451]] PCI AC-Link Controller Audio Device (rev 02)
0000:00:1f.5 [[Multimedia audio controller]]: [[Intel]] Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)

[[Hardware]] SOUND CARD : VIA 8233 (off MSI K7T266 Pro MS6380)

MainBoard: MSI K7T266 Pro (MS6380) @266Mhz - http://www.msi.com.tw/ http://www.msicomputer.com/ Audio: VIA 8233 (on board) - VIA 8366? (MVP4 ?) AC'97

00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233 AC97 Audio  Controller (rev 10)
PCI: 00:11:5: chip 1106,3059 card 1462,3800 rev 10 class 04,01,00 hdr 00

Knoppix 3.3 detects and use OSS via82cxxx_audio driver (instead of alsa's 8233 one)

does via82cXXX fit that 8233 card ? Module loads an playback , but sampling does not seems to work , how to check ?

Also full duplex did not work using gnomemeeting or gphone… how to fix this ?

# apt-get install alsa-modules-2.4.22-1-k7 # dont worked for
# apt-get install alsa-source

Kernel 2.6-t11 works fine

cat /dev/sndstat
Sound Driver:3.8.1a-980706 (ALSA v0.9.7 emulation code)
Kernel: Linux teuz 2.6.0-test11 #7 SMP Thu Dec 11 01:49:43 CET 2003 i686
Config options: 0
Installed drivers:
Type 10: ALSA emulation
Card config:
VIA 8233-Pre at 0xd400, irq 10
Audio devices:
0: VIA 8233-Pre (DUPLEX)
Synth devices: NOT ENABLED IN CONFIG
Midi devices: NOT ENABLED IN CONFIG
Timers:
7: system timer
Mixers:
0: ICEnsemble ICE1232
# q3demo
*------ sound initialization -------
/dev/dsp: Broken pipe
Could not toggle.
# arts q3demo
*------ sound initialization -------
Sorry but your soundcard can't do this

SOUND / CREATIVE LABS / SOUNDBLASTER VIBRA 16

/sbin/modprobe sb io=0x220 irq=5 dma=1 dma16=3

NEOMAGIC

01:00.1 Multimedia audio controller: Neomagic Corporation NM2200 [[MagicMedia  256AV Audio]] (rev 20)
Subsystem: Hewlett-Packard Company MagicMedia 256AV Audio Device on Voyager II
Flags: fast Back2Back, medium devsel, IRQ 10
Memory at fe000000 (32-bit, prefetchable) [[size=4M]]
Memory at fe700000 (32-bit, non-prefetchable) [[size=1M]]

Todo : No Linux support ? please help

MISC

www.inf.upol.cz_skoupil_light_amusements_unix-extinguisher.jpg

multimedia_audio_controller.txt · Last modified: 2012/11/04 21:03 (external edit)
 
Except where otherwise noted, content on this wiki is licensed under the following license: CC Attribution-Share Alike 3.0 Unported
Recent changes RSS feed Donate Powered by PHP Valid XHTML 1.0 Valid CSS Driven by DokuWiki